XBox 360 Controller Problem (PC)

Discussion in 'Video Games and Technology' started by TFXProtector, Nov 14, 2012.

  1. TFXProtector

    TFXProtector TFW2005 Supporter

    Joined:
    Jan 7, 2011
    Posts:
    27,047
    News Credits:
    8
    Trophy Points:
    392
    Likes:
    +38,540
    I bought a 360 controller about a year ago, perhaps even longer now... And I use it to game on my PC. (I've never mastered keyboard + mouse for controls, I realize it's less input lag and more precise, but I just can't get it down pat.)

    I used it this morning to play L4D2 and it worked fine. I disconnected it when I was finished, as I usually do and I heard a springy click after it sat for awhile. (I thought nothing of it.)

    I went to go play Mirror's Edge and nothing. No lights, no movement, and error code 43. (43 is usb device not recognized.) I reinstalled it, I downloaded Microsoft's drivers, it recognized it for about a minute, then stopped.

    Every time I plug it in, all four lights flash, then the upper left one and it works for about 2-3 minutes at best and then dies. I have to disconnect and reconnect and get the same results.

    So, any ideas? I'm thinking the controller just up and died after some rather lengthy usage. I'm thinking it just finally wore out or something. I can't imagine it would work one minute and not the next "just because". I did plug it into my wife's PC and nada. Same error code. (Which also makes me think it's the controller and not Windows.)

    I'll wait for our son to let me use his 360 to test it for sure, but I'm still assuming it just died.

    Any help would be appreciated, thanks in advance. EDIT: Got it working. Required surgery. The triggers have catches so they don't go all the way inside the body casing when being pressed. Well, that catch snapped off and rattled around inside. It knocked loose a 5-6 pin wire set. I plugged it back in and made sure it was seated solidly. Plugged it in and voila, starting working like normal, again.