Heavy/Scratch: WiP Topspin

Discussion in 'Radicons Customs' started by MissingSea, Dec 28, 2012.

  1. MissingSea

    MissingSea Well-Known Member

    Joined:
    Mar 22, 2011
    Posts:
    978
    Trophy Points:
    207
    Location:
    Shropshire
    Likes:
    +1,884
    This is something that I was working on nearly two years ago. I nearly had him completed, but moving house/other projects/family life/lack of inspiration means that he's been sat on my shelf now incomplete for far too long.
    A number of donor bots have gone into this build. The torso, legs and upper arms are WfC Megs to fit in with my Twin Twist custom I did a long while back. Head, chest and chromed spokes are from G1 Topspin. The arm 'wings', forearms, cockpit and rifle are from an Energon Skyblast. The vents on the shoulders, elbows, forearm skeleton and hands are from WfC Cliffjumper.

    Bot Mode:

    [​IMG]

    He's got a good range of articulation:

    [​IMG]

    Alt mode:

    [​IMG]

    Though this is where I hit on the lack of inspiration. The back of the alt mode is fairly open, and you can see the head and hands:

    [​IMG]

    I'm not sure whether I'll find a suitable solution, though I do want to add some detail to the knees before I start painting him up.
     

    Attached Files:

  2. rattraprules98

    rattraprules98 AKA Chr0nus

    Joined:
    Jul 18, 2009
    Posts:
    3,811
    News Credits:
    10
    Trophy Points:
    262
    Location:
    California
    Likes:
    +323
    Pics aren't showing up, OP
     
  3. cliffjumperftw1

    cliffjumperftw1 I have no idea what I'm doing.

    Joined:
    Oct 16, 2011
    Posts:
    1,706
    Trophy Points:
    232
    Location:
    Arizona
    Likes:
    +369
    Same.
     
  4. MissingSea

    MissingSea Well-Known Member

    Joined:
    Mar 22, 2011
    Posts:
    978
    Trophy Points:
    207
    Location:
    Shropshire
    Likes:
    +1,884
    Hmm, not sure why they aren't showing up for both of you (and probably everyone else). The forum was having a funny do when I hit post.
     
    Last edited: Dec 28, 2012
  5. Purple Heart

    Purple Heart Got Well Soon

    Joined:
    Aug 29, 2011
    Posts:
    37,256
    News Credits:
    22
    Trophy Points:
    392
    Likes:
    +61,872
    says invalid attachment...
     
  6. cheetor71

    cheetor71 Autobot

    Joined:
    Apr 14, 2009
    Posts:
    5,145
    Trophy Points:
    191
    Likes:
    +17
    I can't see the pics either. You probably don't have them linked right.
     
  7. MissingSea

    MissingSea Well-Known Member

    Joined:
    Mar 22, 2011
    Posts:
    978
    Trophy Points:
    207
    Location:
    Shropshire
    Likes:
    +1,884
    Hopefully that should have fixed it. Images were showing up for me on my desktop computer, but not the laptop.
     
  8. Carpool

    Carpool Well-Known Member

    Joined:
    Dec 25, 2008
    Posts:
    642
    Trophy Points:
    212
    Likes:
    +44
    Oh my goodness.....
     
  9. MissingSea

    MissingSea Well-Known Member

    Joined:
    Mar 22, 2011
    Posts:
    978
    Trophy Points:
    207
    Location:
    Shropshire
    Likes:
    +1,884
    Went to work trying to find a solution to the gap in alt mode. I rummaged through my parts bin to try and find something that would work. In the end after finding nothing that'd work, I went with a couple of pieces of styrene that swivel around. I've also added some extra detail to the knees. Next step, painting (finally).
     

    Attached Files:

  10. seanb47

    seanb47 FB:SBee'sCustomCreations IG@sbees_custom_creations

    Joined:
    Oct 19, 2012
    Posts:
    2,824
    Trophy Points:
    262
    Location:
    Monterey CA
    Likes:
    +708
    Ebay:
    Interesting.I think it's a good g1 homage with the parts used.Nice efforts!Be great to see when all painted.