FOC Impactor mis-assembled left arm

Discussion in 'Transformers Toy Discussion' started by RavX, Jul 3, 2013.

  1. RavX

    RavX Well-Known Member

    Joined:
    Oct 11, 2008
    Posts:
    1,111
    Trophy Points:
    197
    Likes:
    +76
    Ebay:
    Hey everyone,

    I got my FOC Wreckers in from HTS yesterday and got to open them today and for the most part everything was great, except when I tried to get Impactor into torso mode for Ruination.

    I noticed his left arm would not fold back like the right one and grab the peg behind his torso. It kept popping off. Upon closer examination it looks like his left arm was assemble with a right arm ball-joint peg.

    In light of all the Botcon assembly issues - I am curious if anyone else has this issue with their Impactor or if mine is an isolated case. I checked my Onslaughts (I have retail and SDCC versions) and neither have this problem.

    Sorry the pictures are not great but hopefully you can see what I am talking about. The first is compared to the right Impacator arm (you can see it is just flipped around for the left) and the second is compared to one of my Onslaught arms where you can see the difference.

    Anyone else have this issue?
     

    Attached Files:

  2. King Henrik

    King Henrik Well-Known Member

    Joined:
    Dec 13, 2007
    Posts:
    658
    News Credits:
    3
    Trophy Points:
    147
    Likes:
    +12
    i only have impactor (from HTS) so i haven't tried making the torso mode but comparing mine to yours, the ball joints seem correct on mine.
     
  3. RavX

    RavX Well-Known Member

    Joined:
    Oct 11, 2008
    Posts:
    1,111
    Trophy Points:
    197
    Likes:
    +76
    Ebay:
    Thanks for the reply! Trying to figure out if it is worth going through the HTS hassle for a replacement or just live with it.
     
  4. Hot Shot.

    Hot Shot. Well-Known Member

    Joined:
    Dec 13, 2007
    Posts:
    9,422
    News Credits:
    4
    Trophy Points:
    287
    Likes:
    +1,610
    I had that same issue with my first Onslaught. I returned it.