Rub Symbol Issue?

Discussion in 'Transformers Toy Discussion' started by OptimusTron97, Dec 30, 2010.

  1. OptimusTron97

    OptimusTron97 I like the red water

    Joined:
    Jan 16, 2010
    Posts:
    455
    Trophy Points:
    76
    Likes:
    +0
    I bought a RTS Mindset, and while the rub symbol worked fine at first, it just stopped. Anyone know how to fix this?
     
  2. Seawing

    Seawing Lurker of the depths Moderator

    Joined:
    Dec 7, 2004
    Posts:
    4,138
    News Credits:
    1
    Trophy Points:
    212
    Likes:
    +30
    This is the first I've heard of rub symbol failure. Sorry man...
     
  3. DecepticonSpike

    DecepticonSpike Member of the Scrappy Doo Fan Club

    Joined:
    Dec 8, 2005
    Posts:
    8,969
    News Credits:
    3
    Trophy Points:
    287
    Location:
    Dayton, Ohio
    Likes:
    +1,341
    Twitter:
    Instagram:
    I've had rub symbols stop working on G1 toys after about 20 years, but this is the first time I've heard of a brand new one not working. Maybe you just for your hands on a defective one?
     
  4. Aniel

    Aniel Well-Known Member

    Joined:
    Oct 14, 2010
    Posts:
    60
    News Credits:
    1
    Trophy Points:
    46
    Likes:
    +1
    It's possible that your just in a very cold place and your just not generating enough heat to activate it.
     
  5. Brainchild

    Brainchild Dark Flame Master

    Joined:
    Jun 21, 2010
    Posts:
    5,554
    Trophy Points:
    176
    Likes:
    +1
    It could also be really cold where you are, and seeing as these are heat-sensitive, the weather could be causing it. My RTS Jazz's rubs symbol does nothing when I rub it, but when I put it next to my computer, it immediately activates.
     
  6. xanthax

    xanthax choppaface

    Joined:
    Jul 12, 2009
    Posts:
    5,996
    News Credits:
    2
    Trophy Points:
    197
    Likes:
    +7
    The one on my SDCC Blaster has stopped working too. I didn't think these would do that.
     
  7. Wollstone

    Wollstone Banned

    Joined:
    Jul 26, 2010
    Posts:
    4,238
    Trophy Points:
    151
    Likes:
    +1
    SDCC Blaster has a rub sign?
     
  8. Fishdirt

    Fishdirt Tin Toy Transformer

    Joined:
    Sep 22, 2010
    Posts:
    3,646
    News Credits:
    3
    Trophy Points:
    172
    Likes:
    +7
    Ebay:
    on his crotch. Apparently rubbing it too hard makes it stop working hehe
     
  9. Wollstone

    Wollstone Banned

    Joined:
    Jul 26, 2010
    Posts:
    4,238
    Trophy Points:
    151
    Likes:
    +1
    I've owned this guy for months. How did I not notice that before?
     
  10. ersico

    ersico Well-Known Member

    Joined:
    Aug 16, 2007
    Posts:
    8,197
    News Credits:
    1
    Trophy Points:
    192
    Likes:
    +6
    set it infront of a lamp or space heater for a few minutes and see if it works then
     
  11. AutoBobby

    AutoBobby The Collector

    Joined:
    Nov 15, 2009
    Posts:
    11,889
    Trophy Points:
    277
    Likes:
    +290
    I have my Transformers in the basement where it is pretty cool,and the rub signs don't work at all either.
     
  12. Foster

    Foster Super Mod

    Joined:
    Mar 26, 2003
    Posts:
    32,218
    News Credits:
    7
    Trophy Points:
    327
    Likes:
    +71
    Try a hair dryer.
     
  13. Deceptichage

    Deceptichage Decepticon Land Pirate

    Joined:
    Aug 11, 2006
    Posts:
    2,606
    News Credits:
    5
    Trophy Points:
    186
    Likes:
    +10
    You could always exchange it. :lol 

    Seriously it's probably just the cold like everyone has mentioned. None of my RTS symbols show up unless I place it close to the space heater.
     
  14. Wollstone

    Wollstone Banned

    Joined:
    Jul 26, 2010
    Posts:
    4,238
    Trophy Points:
    151
    Likes:
    +1
    Rub your hands together quickly for a few seconds and then press your palm over the rub sign area firmly for a moment.
     
  15. TheGame2K5

    TheGame2K5 Well-Known Member

    Joined:
    Jun 20, 2009
    Posts:
    2,937
    News Credits:
    1
    Trophy Points:
    172
    Likes:
    +19
    I make fun of my wife because she cant get the rub signs to work on the new figs. I can get them to change after putting my thumb on them for like 3 secs however.lol.
     
  16. mx-01 archon

    mx-01 archon Well-Known Member

    Joined:
    Jan 26, 2003
    Posts:
    15,925
    News Credits:
    1
    Trophy Points:
    332
    Likes:
    +722
    If it actually doesn't work, it could be that the plastic film on top of the rubsign fell off. If that's the case, then it's dead.
     
  17. Fishdirt

    Fishdirt Tin Toy Transformer

    Joined:
    Sep 22, 2010
    Posts:
    3,646
    News Credits:
    3
    Trophy Points:
    172
    Likes:
    +7
    Ebay:

    Cause it's on the crotch. My guess anyway haha
     
  18. Dolza_Khyron

    Dolza_Khyron Well-Known Member

    Joined:
    Jul 7, 2002
    Posts:
    20,206
    Trophy Points:
    387
    Likes:
    +186
    awe bleh it's a rub symbol we have all seen them work before! :lol 
     
  19. guard convoy

    guard convoy The Big Daddy

    Joined:
    Mar 19, 2009
    Posts:
    14,054
    News Credits:
    17
    Trophy Points:
    227
    Likes:
    +41
    maybe because you don't spend your time looking at and fondling toy robot crotches?

    none of my RTS rubsigns work, oh well, don't really care for them anyways
     
  20. Gingerchris

    Gingerchris Telly-headed Tyrant

    Joined:
    Feb 17, 2005
    Posts:
    14,834
    News Credits:
    6
    Trophy Points:
    287
    Likes:
    +143
    Didn't your mother ever warn you that if you rubbed your logo too much it'd go blind?

    I guess it's either too cold or just defective. Whack a normal faction logo on there or a rub from Reprolables. Are they planning on making the new RtS type?

    I had some of my oldest G1 figures out of storage recently and the rub stickers worked fine on those.
    I'd say it just varies from sticker to sticker, today just as back then.
     

Share This Page