Rotf Mixmaster-possible assembly error?

Discussion in 'Transformers Toy Discussion' started by Torque, Jun 16, 2009.

  1. Torque

    Torque The WORDSMITH

    Joined:
    Dec 17, 2007
    Posts:
    11,327
    News Credits:
    6
    Trophy Points:
    221
    Likes:
    +6
    i watched a few reviews of Mixmaster after getting my own, as i coulnt get the cab to peg into his back. i examined the instructions, the toy, and the reviews and realized-theres a piece upside down!

    sadly i dont have pictures, but i can say almost certainly that the cab is that upside down piece. when looking at the long pieve that connects to the cab from the robot himself, i noticed that the joint that bends bends the wrong direction. now that can be easily fixed by spinning the piece, but now the cab is upside down, so im again stuck. i think the easy fix would be to hammer out the pin in the joint that connects the bumper to the piece that connects to the cab, flip the cab, then hammer it back in.


    does anyone else have this issue, or is it just mine and the ones in the reviews? if in vehicle mode, look at the bottom-if you can see the bending part of the joint, and not the little rectangles, then yours is upside down as well.
     
  2. Torque

    Torque The WORDSMITH

    Joined:
    Dec 17, 2007
    Posts:
    11,327
    News Credits:
    6
    Trophy Points:
    221
    Likes:
    +6
    also, since i want to try and flip it to see if it helps-how do i get the pin out? and if i get it out, how do i get it back in, and will it fall out? new to that.
     
  3. kamuix

    kamuix weeeeee

    Joined:
    Jan 8, 2008
    Posts:
    867
    Trophy Points:
    101
    Likes:
    +0
    yeah i have the same issue too, its during the battle mode transformation. it's just weird. for the pin, i'm not even willing to mess with that. i have a feeling with enough force that whole plastic bar will snap.
     
  4. MegaHavok

    MegaHavok Well-Known Member

    Joined:
    Jul 12, 2002
    Posts:
    4,506
    News Credits:
    18
    Trophy Points:
    186
    Likes:
    +18
    i havent had a problem yet but I havent tried weapons mode
     
  5. Torque

    Torque The WORDSMITH

    Joined:
    Dec 17, 2007
    Posts:
    11,327
    News Credits:
    6
    Trophy Points:
    221
    Likes:
    +6
    how did you get it in place for bot mode? i have to fight it, and it never feels solid when its in.
     
  6. kamuix

    kamuix weeeeee

    Joined:
    Jan 8, 2008
    Posts:
    867
    Trophy Points:
    101
    Likes:
    +0
    in robot mode? for me i have the whole bar straight and bent at the cab towards the lil hole on the cannon. it takes a bit, but u can kinda fit the pin in the cab snugly into the pin. i tried variations with the bits bent and what not, but it's easier with it straight.
    some pics:
    [​IMG]

    [​IMG]
     
  7. Deceptigtar

    Deceptigtar Sworn Decepticon Assassin

    Joined:
    May 24, 2006
    Posts:
    13,007
    News Credits:
    63
    Trophy Points:
    277
    Likes:
    +64
    Ebay:
    U guys do know there is a piece inside the cab u flip out that pegs in the back. It's inside on the top of the cab.
     
  8. Matterzero

    Matterzero Well-Known Member

    Joined:
    Dec 16, 2008
    Posts:
    326
    Trophy Points:
    76
    Likes:
    +0
    I've got he same problem I noticed it Sunday when I figured I give his cannon mode a try and I notice his cab wasn't working the way the instructions showed, at first I though it was just crappy Hasbro instructions but then I noticed the instruction had the joint assembled a different way, so I just put him back into robot mode and placed him on my shelf.
     
  9. kamuix

    kamuix weeeeee

    Joined:
    Jan 8, 2008
    Posts:
    867
    Trophy Points:
    101
    Likes:
    +0
    yeah i stopped caring lol.

    yeah deceptigtar, i know about the peg. if you look in my second pic u can see the peg (the gray blue) near the cannon. it's not pegged in all the way, i left it out partially.
     
  10. Heat Blast

    Heat Blast Laserbeak's Stunt Double

    Joined:
    Jun 14, 2009
    Posts:
    770
    Trophy Points:
    116
    Likes:
    +0
    Same problem, we are working on it now. I will post it it goes...
     
  11. ORIO

    ORIO Plant-Based Bot Super Mod News Staff

    Joined:
    Jul 2, 2002
    Posts:
    20,023
    News Credits:
    36
    Trophy Points:
    327
    Likes:
    +51
    Ebay:
    Over in Radicons, they have a whole tutorial thread about removing pins
     
  12. Scantron

    Scantron Well-Known Member

    Joined:
    Oct 3, 2004
    Posts:
    8,249
    News Credits:
    3
    Trophy Points:
    211
    Likes:
    +3
    It's discussed extensively in the thread for that toy in the Feedback Forum, but yeah, that one joint is incorrect on every copy of the figure.
     
  13. Heat Blast

    Heat Blast Laserbeak's Stunt Double

    Joined:
    Jun 14, 2009
    Posts:
    770
    Trophy Points:
    116
    Likes:
    +0
    I fixed it! It's like a new figure! Also, the sets of wheels that are attached to the arms go in holes on the bottom of the cab in "Battle Mode". It is not in the instructions and is impossible without fixing Mixmaster's assembly error.
     
  14. ElekTriC

    ElekTriC Well-Known Member

    Joined:
    Jan 12, 2007
    Posts:
    4,631
    News Credits:
    6
    Trophy Points:
    202
    Likes:
    +184
    good for you! now tell us? :p 
     
  15. Dinobot Nuva

    Dinobot Nuva Johnny 3 Tears Veteran

    Joined:
    Apr 2, 2006
    Posts:
    7,968
    News Credits:
    15
    Trophy Points:
    221
    Likes:
    +15
    I thought it was just me. Oh well. Wonder if they'll fix it for the G1 repaint? Not that that would be enough for me to spring for it.
     
  16. xOPtimUsZErOx

    xOPtimUsZErOx Well-Known Member

    Joined:
    Jun 6, 2009
    Posts:
    236
    News Credits:
    1
    Trophy Points:
    56
    Likes:
    +1
    looks like i have a bigger problem i just looked at my mixmaster and just noticed that he doesn't have a knee on his left side fml i threw away the box last night
     
  17. Heat Blast

    Heat Blast Laserbeak's Stunt Double

    Joined:
    Jun 14, 2009
    Posts:
    770
    Trophy Points:
    116
    Likes:
    +0
    Well, my dad had a special tool. I can't remember the name...
     
  18. Heat Blast

    Heat Blast Laserbeak's Stunt Double

    Joined:
    Jun 14, 2009
    Posts:
    770
    Trophy Points:
    116
    Likes:
    +0
    They better!
     
  19. harrismonkey

    harrismonkey Well-Known Member

    Joined:
    Apr 10, 2009
    Posts:
    5,311
    News Credits:
    1
    Trophy Points:
    202
    Likes:
    +41
    I have the same problem (although it sounds like everyone does).

    Never turned mine into it's battlemode. Doesn't really cause an issue in bot mode so I haven't bothered with fixing it.
     

Share This Page