Problems with Concept Bumblebee

Discussion in 'Transformers Toy Discussion' started by Taker, Aug 20, 2007.

  1. Taker

    Taker Chilean TF Fan

    Joined:
    Jul 30, 2006
    Posts:
    831
    Trophy Points:
    136
    Likes:
    +0
    Hi everyone.

    First time transforming him to robot mode, perfect.

    However, when trying to turn him into vehicle mode, I have some problems with his front section. I think I screwed his automorph, cos when I rise the front section of the car, the arms don't move at all, and I have to move them myself using some force.

    I think the engineering on this figure is not so good. In fact, it's the first transformer that gives me this kind of problem.

    Does anyone have the same problem?
     
  2. pscoop

    pscoop Dead inside

    Joined:
    Dec 16, 2006
    Posts:
    5,449
    News Credits:
    7
    Trophy Points:
    176
    Likes:
    +7
    The section with the doors has to be turned out and pulled out all the way. Sometimes I have to rotate the panels a little to get it back. I have never had any serious issues with the section though. It is was better that classic Bee's. Maybe you got a lemon. Pics would help though.
     
  3. SPLIT LIP

    SPLIT LIP Dry built

    Joined:
    Oct 22, 2005
    Posts:
    66,405
    News Credits:
    2
    Trophy Points:
    407
    Location:
    agile house
    Likes:
    +912
    I don't think his arms are connected to the automorph that way, you have to pull them out manually. Remember, they clip out to a certain length.
     

Share This Page