Problem with United Frenzy's shoulder clips

Discussion in 'Transformers Toy Discussion' started by retrolewp, May 14, 2011.

  1. retrolewp

    retrolewp Well-Known Member

    Joined:
    Jan 4, 2011
    Posts:
    79
    Trophy Points:
    56
    Likes:
    +0
    I just got these guys in the mail today. They are awesome. However, Frenzy (in this case, the blue one) has a factory error on the shoulder clips that attach to the upper torso in robot mode. They were cut too short. They do stay on, but just barely. I can't fiddle around with it without them detaching. What can I do about this issue?
     
  2. rcal7109

    rcal7109 Maximal

    Joined:
    Jul 5, 2008
    Posts:
    409
    Trophy Points:
    76
    Likes:
    +0
    :useless  especially for those that don't have these yet.
     
  3. -l-AYATOLLAH-l-

    -l-AYATOLLAH-l- Well-Known Member

    Joined:
    Oct 23, 2008
    Posts:
    537
    Trophy Points:
    116
    Likes:
    +0
    Mine has no problems.
     
  4. BlueAngel_Bolt

    BlueAngel_Bolt I'M REALLY FEELING IT

    Joined:
    Oct 2, 2008
    Posts:
    2,561
    News Credits:
    1
    Trophy Points:
    172
    Likes:
    +3
    I don't have them personally, but usually for a situation like that, apply a thin layer of nail polish or super glue to the tab. It won't make it longer, but once it dries, it'll be thicker and less likely to come out on you.
     
  5. retrolewp

    retrolewp Well-Known Member

    Joined:
    Jan 4, 2011
    Posts:
    79
    Trophy Points:
    56
    Likes:
    +0
    Sorry about that, here's an image of what I'm talking about.

    51.jpg

    Rumble is just fine though.
     

Share This Page