Problem with PE Rewinder & Ejector

Discussion in 'Transformers 3rd Party Discussion' started by Acidophilus, May 30, 2012.

  1. Acidophilus

    Acidophilus Well-Known Member

    Joined:
    Sep 21, 2005
    Posts:
    1,631
    News Credits:
    2
    Trophy Points:
    176
    Likes:
    +2
    I posted this in the 3rd party review section:

    I got these two yesterday. I already had the PE Rumble & frenzey figure, and the QC on them are great, no problems.

    On Rewinder the legs slide off if they are moved forward, then to the side, with no resistance.

    Eject's left leg is the same, but the right leg would barely stay on the ball when I had just taken it out of the package, but after moving it around a bit it won't even stay on the ball in any poisition.

    I think I got a dud Ejector, and have already emailed TFsource about the problem, but do the legs come off so easily on all these figures? Or at least in the way forementioned?
     
  2. ORIO

    ORIO Plant-Based Bot Super Mod News Staff

    Joined:
    Jul 2, 2002
    Posts:
    20,166
    News Credits:
    36
    Trophy Points:
    392
    Likes:
    +133
    Ebay:
    Mine have no problems.
     
  3. Transbot90210

    Transbot90210 Banned

    Joined:
    Jul 1, 2002
    Posts:
    14,849
    News Credits:
    7
    Trophy Points:
    236
    Likes:
    +7
    Trouble free on my end too.
     
  4. Acidophilus

    Acidophilus Well-Known Member

    Joined:
    Sep 21, 2005
    Posts:
    1,631
    News Credits:
    2
    Trophy Points:
    176
    Likes:
    +2
    Thanks for the feedback guys. I guess I just got a random flawed one I'm just going to ask for a replacement.
     
  5. TFao

    TFao Well-Known Member

    Joined:
    Mar 30, 2011
    Posts:
    3,103
    Trophy Points:
    202
    Likes:
    +158
    I only have a PE Ninja (same mold right?), but no issues with that one.
     
  6. General Tekno

    General Tekno Self-Styled #1 Lugnut Fan

    Joined:
    Jun 26, 2006
    Posts:
    10,233
    News Credits:
    227
    Trophy Points:
    342
    Location:
    The Teknodrome
    Likes:
    +517
    I have that issue on one of Ejector's legs. All the other limbs are fine though, and Rewinder is great.
     
  7. MECHADOOM

    MECHADOOM I'm Doombot and I know it

    Joined:
    Jun 25, 2004
    Posts:
    1,731
    Trophy Points:
    177
    Likes:
    +16
    I too have this problem with Ninja (the pink and white version), but really it doesn't bother me. I just pop the leg back on. I can still pose it fine. But if the problem with yours is comprimising pose-ability, looking into replacements would be recommended. It would just suck if the replacements had the same problem.
     
  8. Acidophilus

    Acidophilus Well-Known Member

    Joined:
    Sep 21, 2005
    Posts:
    1,631
    News Credits:
    2
    Trophy Points:
    176
    Likes:
    +2
    I guess I'm not the only one. I read the Feedback thread here for theses two here before I made the purchase, and read that the quality had improved since the PE-01, so I really didn't expect any problem with these two, seeing how my Rumble, and Frenzy had no problems.

    I think part of it may be the design, of the thigh socket, it's smaller, and thinner then the ones on PE-01.

    I e-mailed TFSource on Tuesday about the problem, but have heard nothing back yet.
     
  9. Orodruin

    Orodruin @deathformer TFW2005 Supporter

    Joined:
    Aug 2, 2004
    Posts:
    11,393
    News Credits:
    4
    Trophy Points:
    287
    Likes:
    +5
    Mine are fine. You could try the floor polish/super glue trick on the ball joints too, it might be less hassle than replacing it.
     
  10. Acidophilus

    Acidophilus Well-Known Member

    Joined:
    Sep 21, 2005
    Posts:
    1,631
    News Credits:
    2
    Trophy Points:
    176
    Likes:
    +2
    TFSource contacted me back about the problem. This was their reply:

    "I'm sorry to hear that you received a faulty figure. I have removed another PE-05 from our inventory & are shipping it out to you today via First Class Mail.

    There is no need to return the defective figure to us, though I would recommend hanging onto it in case you run into another issue with the figure down the road.


    Best Regards"

    That is great service! I really want to say I'm very pleased that they are making this so easy. Though it does make me wonder how often they have had this problem with the PE-05 mold.

    Anyway I'm VERY PLEASED with the customer service at TFSource.


    Thanks for the suggestion. If the new one is faulty, That's what I'll do.
     
  11. autobot prowl

    autobot prowl Well-Known Member

    Joined:
    Sep 20, 2007
    Posts:
    2,871
    Trophy Points:
    262
    Likes:
    +561
    Wow, that is really good service!
     
  12. RedAlert Rescue

    RedAlert Rescue Banned

    Joined:
    May 12, 2003
    Posts:
    13,220
    News Credits:
    5
    Trophy Points:
    236
    Likes:
    +11
    Check the ball joint and see if it's round if there's a flat spot on it just dab a little varnish on the flat spot that should solve your issue.
     

Share This Page