Problem with Classic 2.0 Tankor

Discussion in 'Transformers Toy Discussion' started by Enercron, Jul 29, 2008.

  1. Enercron

    Enercron Member

    Joined:
    Apr 14, 2004
    Posts:
    7
    Trophy Points:
    66
    Likes:
    +0
    I got Classic 2.0 Tankor yesterday, but I am having a problem getting his right leg to come out. It only comes out a small bit, if at all. Has anyone else had that problem?
     
  2. Taker

    Taker Chilean TF Fan

    Joined:
    Jul 30, 2006
    Posts:
    831
    Trophy Points:
    136
    Likes:
    +0
    Me not. Both legs move fine on mine.
     
  3. Sol Fury

    Sol Fury The British Butcher Administrator News Staff

    Joined:
    Nov 22, 2002
    Posts:
    35,576
    News Credits:
    4
    Trophy Points:
    317
    Likes:
    +34
    Facebook:
    Instagram:
    Mine are okay. Can you post a pic of the leg, it might be something like a QC problem (a left leg part where there should be a right one interfering with the transformation, it is not totally unheard of)
     
  4. LXL_Guy

    LXL_Guy Well-Known Member

    Joined:
    May 12, 2008
    Posts:
    1,419
    Trophy Points:
    137
    Likes:
    +1
    I had the same problem and completely destroyed the toy in frustration.
     
  5. TheInformation

    TheInformation The ghost of an automaton

    Joined:
    Jul 17, 2008
    Posts:
    591
    Trophy Points:
    101
    Likes:
    +0
    Then you seriously need to chill out. Your response to an obstacle shouldn't be "get mad until I break something." Especially something that you paid money for. What a waste.

    OP, don't go that route. Like Sol Fury said, take a pic of the leg and let us see what's up.
     
  6. Sportimus

    Sportimus Well-Known Member

    Joined:
    Jun 23, 2008
    Posts:
    4,901
    News Credits:
    1
    Trophy Points:
    172
    Likes:
    +6
    Mine need some muscle to get out both legs, but they do come out.
     
  7. Enercron

    Enercron Member

    Joined:
    Apr 14, 2004
    Posts:
    7
    Trophy Points:
    66
    Likes:
    +0
    I wish I could put a picture up, I don't have a camera. Yeah it frustrated the hell outta me, so I threw my hands up and said, "Forget this! I'll try it again when I have more time and more patience". Plus, when I tried using muscles, all it did was it kept popping the leg out of the little black connector that connects the leg to the torso.
     
    Last edited: Jul 29, 2008
  8. Opticron Primal

    Opticron Primal Comin' up OOOs!

    Joined:
    Aug 1, 2007
    Posts:
    10,340
    News Credits:
    5
    Trophy Points:
    216
    Likes:
    +5
    Hmmm....strange. Perhaps some plastic blocking the path? Never had that problem.
     
  9. LXL_Guy

    LXL_Guy Well-Known Member

    Joined:
    May 12, 2008
    Posts:
    1,419
    Trophy Points:
    137
    Likes:
    +1
    Well when I meant destroyed I should have explained a little more. I basically tried to see why the leg kept popping off the figure whenever I tried to slide it out but even with the slightest easy pull it'd still pop out. I eventually took some needle nose pliers (bad on my part) and stripped the outside of the plastic. Couldn't ever figure it out and just left it as is in robo mode. Otherwise I'm gonna get another and use the broken one for some sort of customization.
     
  10. Switchblade

    Switchblade Just a raggedy man

    Joined:
    Jan 17, 2005
    Posts:
    12,898
    News Credits:
    1
    Trophy Points:
    262
    Likes:
    +33
    I'd either return it for a new one or try opening up the leg and seeing what's causing the problem.
     
  11. Takara_destron

    Takara_destron Mainly lurking these days

    Joined:
    Sep 30, 2007
    Posts:
    7,518
    Trophy Points:
    221
    Likes:
    +0
    Ebay:
    Mine were riduculously stiff (to the point I thought I was ripping the leg off), but both came out in the end.
     

Share This Page