Possible problem with Cyberverse Evac?

Discussion in 'Transformers Toy Discussion' started by Optronix1087, May 18, 2012.

  1. Optronix1087

    Optronix1087 Well-Known Member

    Joined:
    Apr 11, 2011
    Posts:
    260
    News Credits:
    3
    Trophy Points:
    87
    Likes:
    +27
    I got the Cyberverse Evac last night, pretty cool little figure and I look forward to getting the surely overpriced deluxe in the future. I noticed he has some rust on both of the front wheels pins and the pins that holds the arms to the torso. Anyone else notice this? It's not a horrible problem but I imagine it would eventually cause problems (aside from the cosmetic one).
     
  2. Erland

    Erland Well-Known Member

    Joined:
    Jan 30, 2012
    Posts:
    3,982
    News Credits:
    2
    Trophy Points:
    187
    Likes:
    +50
    I don't have that issue with mine..

    however I'm curious, isn't evac the same mold as WFC Jazz? Maybe it's just me...
     
  3. BlueAngel_Bolt

    BlueAngel_Bolt I'M REALLY FEELING IT

    Joined:
    Oct 2, 2008
    Posts:
    2,592
    News Credits:
    1
    Trophy Points:
    172
    Likes:
    +13
    Mine has rust on the pins too, though it doesn't hinder wheel rotation on mine at all. Still, I wonder what the cause of it is?
     
  4. Optronix1087

    Optronix1087 Well-Known Member

    Joined:
    Apr 11, 2011
    Posts:
    260
    News Credits:
    3
    Trophy Points:
    87
    Likes:
    +27
    So there does seem to be a possible running problem then.
     
  5. Swoop Dogg

    Swoop Dogg me King!

    Joined:
    Jun 22, 2003
    Posts:
    2,813
    News Credits:
    1
    Trophy Points:
    237
    Likes:
    +172
    My Evac has the rust too.
     
  6. Switchblade

    Switchblade Just a raggedy man

    Joined:
    Jan 17, 2005
    Posts:
    13,452
    News Credits:
    1
    Trophy Points:
    312
    Likes:
    +270
    My Evac is spotless. Not even a little bit of discoloration on the metal.
     
  7. QmTablit

    QmTablit Disguise: Check. Robot...

    Joined:
    Nov 7, 2008
    Posts:
    9,427
    Trophy Points:
    176
    Likes:
    +3
    Yeah, mine has rust on the left shoulder pin. Also looks like the right shoulder's capable of rusting in the future.

    Both the legs' pins are clean and shiny though.
     
  8. Mudslide

    Mudslide Familiar and faceless

    Joined:
    Aug 24, 2009
    Posts:
    950
    Trophy Points:
    112
    Likes:
    +22
    This is interesting, mine has it as well. I just figured I got the figure with my name on it.
     
  9. Fallout

    Fallout Well-Known Member

    Joined:
    Nov 26, 2011
    Posts:
    12,927
    News Credits:
    2
    Trophy Points:
    277
    Likes:
    +1,434
    guess i'm not the only one then.

    mine only has them on the front, the back is spotless. doesn't seem to be anything outside of cosmetic.
     
  10. OmegaSupreme235

    OmegaSupreme235 Well-Known Member

    Joined:
    Jan 5, 2012
    Posts:
    562
    Trophy Points:
    101
    Likes:
    +1
    Ebay:
    Shit I did'nt even notice but yeah mine does also
     
  11. Jetbolt

    Jetbolt Maximal Air Commander

    Joined:
    Dec 6, 2009
    Posts:
    18,729
    News Credits:
    19
    Trophy Points:
    317
    Location:
    Ararat, NC
    Likes:
    +13,803
    Ebay:
    Facebook:
    Twitter:
    Google+:
    Instagram:
    Flickr:
    YouTube:
    I notice it with the one I have too. Though not a issue now, took a black sharpie and just black out the pins.
     

Share This Page