Customs: Omega Supreme Help

Discussion in 'Creative General Discussion' started by Gnaw, Feb 6, 2007.

  1. Gnaw

    Gnaw Banned

    Joined:
    Aug 26, 2005
    Posts:
    4,548
    Trophy Points:
    186
    Likes:
    +0
    Hi guys, I have a problem with my G1 Omega Supreme...well quite a few. Today was my toy clean up day, where I dust, swab, wipe and shine my toys. When I got to my OS I finally decided to test his electronics. Unfortunately I noticed the blue acid stuff on his prongs.

    So my first help question is what I should do to clean those prongs?

    I have already used a plastic nail file and have sanded off most of it. There's still some deep brown patches where I could reach it.

    I have also used Vinegar to weaken the acid strength (Dad's suggestion). It worked good.

    While working on that I tested the wheels and found that they didn't spin/ buckled up. Obviously it had to be the gears. So I oppened her up, and low and behold one of the prongs that held a gear had broken. Me and my Dad are going to glue a thin piece of plastic or cooper to fix that issue.

    **pictures via ASC II**

    | <------ Broken prong where gear is placed
    | |
    ---

    My last problem is that I accidentatly tipped his chassy over and all the gears fell out. I know where 3/4 of them go but not the rest.

    Anyone have any pictures of his insides?


    Thank you in advance for any help you offer. I just want to get this sucker working. Worst case scenario is I buy a working tank, but I really want a cheaper solution.
     
  2. Gnaw

    Gnaw Banned

    Joined:
    Aug 26, 2005
    Posts:
    4,548
    Trophy Points:
    186
    Likes:
    +0
    Does noone have anything?
     
  3. MegaMoonMan

    MegaMoonMan www.megamoonman.com TFW2005 Supporter

    Joined:
    Jul 13, 2004
    Posts:
    17,235
    News Credits:
    3
    Trophy Points:
    322
    Likes:
    +29
    Ebay:
    YouTube:
    I looked for pics, but I couldn't find any. I could probably fix it if you sent all the parts to me. I'm good with shit like that.

    I'm serious, I would fix it for you for free. All you would have to pay is shipping here and back.
     
  4. Gnaw

    Gnaw Banned

    Joined:
    Aug 26, 2005
    Posts:
    4,548
    Trophy Points:
    186
    Likes:
    +0
    Like, all I need to get fixed at this moment is getting the gears in their right places. I fixed the prong, but it's just that the gears aren't working where I've put them back. Thanks for the offer but I don't want to spend cash on repairing it. I'll probably leave it standing with working elec or just scrap it. Sell it for junk parts.
     
  5. Gnaw

    Gnaw Banned

    Joined:
    Aug 26, 2005
    Posts:
    4,548
    Trophy Points:
    186
    Likes:
    +0
    Okay, I solved 2 of the 3 problems. Found where all the gears go and fixed the prong. I just have to grind it out a bit more to make it looser. But I would love tips on how to get rid of the battery acid and make a better connection. The motot does work, I just need a battery connection. PLEASE HELP! I will put your name in my sig with the word love used multiple times. I wanna get this sucker going and watch him go along the track.
     
  6. MegaMoonMan

    MegaMoonMan www.megamoonman.com TFW2005 Supporter

    Joined:
    Jul 13, 2004
    Posts:
    17,235
    News Credits:
    3
    Trophy Points:
    322
    Likes:
    +29
    Ebay:
    YouTube:
    Are you sure it's the connections? Have you tested the motor at all? The wires that connect the motor to the contacts could be bad as well, you may have to re-solder them. If the corrosion is as bad as you say, it easily could have eaten through the ends of them.

    Get a couple spare wires and connect the motor directly to a battery.
     
  7. Gnaw

    Gnaw Banned

    Joined:
    Aug 26, 2005
    Posts:
    4,548
    Trophy Points:
    186
    Likes:
    +0
    Yeah we did that. GOt a battery and some wires and did end to end connections. It ran. Argh! This thing is driving me insane! Once I get the gear part running I'll focus on the connections themselves. If I don't get those working then i'll leave it as a display piece until I can get a spare tank + all the tracks and armor pieces at Transformerscon this year. Besides, I bought the sucker for 70 CAD , so I guess I got my monies worth *shrugs*.
     
  8. fschuler

    fschuler Member TFW2005 Supporter

    Joined:
    Nov 28, 2005
    Posts:
    2,202
    Trophy Points:
    216
    Likes:
    +0
    Hey dude,

    I can get you a pic of his guts if you can wait till tomorrow.
     
  9. Gnaw

    Gnaw Banned

    Joined:
    Aug 26, 2005
    Posts:
    4,548
    Trophy Points:
    186
    Likes:
    +0
    Sick! That'd be great! I can. We are waiting to the wekend to continue his operation.
     
  10. fschuler

    fschuler Member TFW2005 Supporter

    Joined:
    Nov 28, 2005
    Posts:
    2,202
    Trophy Points:
    216
    Likes:
    +0
    WAL-LA!!!

    [​IMG]
     
  11. Kaijumaster

    Kaijumaster 335

    Joined:
    Sep 29, 2004
    Posts:
    7,320
    News Credits:
    12
    Trophy Points:
    211
    Likes:
    +12
    SCRAP IT! sell it cheap! I'll buy it! lol
     
  12. Gnaw

    Gnaw Banned

    Joined:
    Aug 26, 2005
    Posts:
    4,548
    Trophy Points:
    186
    Likes:
    +0
    Thanks dude! Does your Omega Work?
     
  13. Gnaw

    Gnaw Banned

    Joined:
    Aug 26, 2005
    Posts:
    4,548
    Trophy Points:
    186
    Likes:
    +0
    We'll see. I have to work on it again.
     
  14. Chaos Muffin

    Chaos Muffin Misadventure Veteran

    Joined:
    Mar 26, 2004
    Posts:
    28,751
    Trophy Points:
    322
    Likes:
    +4
    That's alot of gears
     

Share This Page