My Masterpiece Prime's chest stopped lighting

Discussion in 'Transformers Toy Discussion' started by Screamer52488, Mar 16, 2012.

  1. Screamer52488

    Screamer52488 Well-Known Member

    Joined:
    Jun 10, 2009
    Posts:
    117
    Trophy Points:
    61
    Likes:
    +0
    Ebay:
    As the title describes my Masterpiece Prime's matrix stoppped lighting. I replaced the batteries but that didn't work. Is it the bulb? If so can it be replaced? What else could it be? Anyone else have this problem?
     
  2. Wyvern

    Wyvern Velvet Sanchez

    Joined:
    Feb 7, 2003
    Posts:
    8,364
    News Credits:
    1
    Trophy Points:
    226
    Likes:
    +5
    Might be the wiring. Try another set of batteries also.
     
  3. Thundershot

    Thundershot The guy with 28 Sweeps

    Joined:
    Dec 15, 2002
    Posts:
    23,638
    News Credits:
    10
    Trophy Points:
    362
    Location:
    Mineral Ridge, OH, USA
    Likes:
    +2,751
    Ebay:
    He cured the hate plague... the Matrix is empty now...
     
  4. Motor_Master

    Motor_Master Lets the balls touch

    Joined:
    Jul 30, 2002
    Posts:
    11,862
    News Credits:
    7
    Trophy Points:
    372
    Location:
    New Hampshire
    Likes:
    +213
    ...so it's up to all of us to fill it again, with the fresh batteries that we get from this day on!
     
  5. process

    process Hanlon's razor Veteran

    Joined:
    Dec 1, 2008
    Posts:
    7,879
    News Credits:
    35
    Trophy Points:
    292
    Likes:
    +545
    Ebay:
    Take the entire unit out, and disassemble as much as you can. Check the batteries first, to see if there's been any corrosion that might be preventing the circuit from completing. Test the switch directly, or try bypassing it with some bare wire.

    Having replaced the LED myself, I can tell you it's a bit of a pain. From what I recall, the soldered connection is on the same side the LED is on, making it really difficult to get off and reattach. The LED should be good for life, so I have a hard time suspecting it's that, unless there's a broken connection somewhere.

    It's a simple circuit, so there aren't many things that could be wrong. If the light works when it's not installed in Prime's chest, consider the switch on the roof of the cab might be broken.
     
  6. Gilgamesh

    Gilgamesh Mostly Harmless

    Joined:
    May 5, 2009
    Posts:
    5,011
    News Credits:
    1
    Trophy Points:
    247
    Likes:
    +254
    Did he turn gray? Was Magnus able to deal with it?
     
  7. Grimmjow

    Grimmjow Blastcage

    Joined:
    Feb 2, 2012
    Posts:
    3,421
    Trophy Points:
    177
    Location:
    Georgia, USA
    Likes:
    +38
    Funny, when I got mine, the light didn't seem to work, even after I replaced the batteries, but then one day it randomly was able to light up. I thought mine used to have a problem...but perhaps there never was.
     
  8. Dolza_Khyron

    Dolza_Khyron Well-Known Member

    Joined:
    Jul 7, 2002
    Posts:
    20,305
    Trophy Points:
    412
    Likes:
    +272
    he should try going to care-alot to get a refill :lol 
     
  9. tikgnat

    tikgnat Baweepgranaweepninnybong. TFW2005 Supporter

    Joined:
    Jul 2, 2002
    Posts:
    25,674
    News Credits:
    2
    Trophy Points:
    472
    Location:
    Beneath the Loft, London, UK
    Likes:
    +8,803
    Ebay:
    Twitter:
    Huh, this thread reminds me, I have to check the battery compartments of my MP Convoy, Ultra Magnus and Optimus Prime... I can't remember if I left them in or not.
     
  10. wildfly

    wildfly Right notes. Wrong order.

    Joined:
    Feb 7, 2009
    Posts:
    14,400
    News Credits:
    35
    Trophy Points:
    277
    Location:
    Location: Location:
    Likes:
    +460
    MP Grimlock and Megatron?
     
  11. Stepper

    Stepper Well-Known Member

    Joined:
    Oct 6, 2011
    Posts:
    10,235
    News Credits:
    1
    Trophy Points:
    217
    Likes:
    +24
    It maybe the battery leak & has damaged the internal part
     
  12. Screamer52488

    Screamer52488 Well-Known Member

    Joined:
    Jun 10, 2009
    Posts:
    117
    Trophy Points:
    61
    Likes:
    +0
    Ebay:
    The shoulder switch is fine. I checked that. When I took the old batteries out, they looked fine with no signs of leaking or corrosion(sp). All he's done is stand on a shelf so I don't know how any wiring would have been damaged but it's the only thing left I can think of.
     

Share This Page