Launcher won't hold missile

Discussion in 'Transformers Toy Discussion' started by Soundblaster1, Aug 6, 2012.

  1. Soundblaster1

    Soundblaster1 The Heisenberg of Toys

    Joined:
    Oct 4, 2004
    Posts:
    14,024
    News Credits:
    11
    Trophy Points:
    257
    Likes:
    +16
    I recently bought a something from someone on the boards (I figure it isn't his fault, so I don't want to mention anything that will potentially tarnish anyone's reputation) but I will mention what mold I'm referring to because of the uniqueness of the launcher.

    It's the BW Tarantulas/Blackarachnia mold, and the launcher won't hold any of the missiles for any length of time. Missile goes in, missile fires. The triggers look fine (the top one and the bottom one) and I'm not seeing anything inside the launcher that would prevent it from holding the missile (the "tooth" is still very much on the trigger).

    Is there any way to fix it and still preserve the spring-loaded qualities of the missile launcher, or am I SOL?
     
  2. LCDR Blindside

    LCDR Blindside Banned

    Joined:
    Apr 1, 2012
    Posts:
    4,527
    News Credits:
    1
    Trophy Points:
    151
    Likes:
    +3
    Do you see the trigger engage as you push the missile in?
     
  3. stepsongrapes

    stepsongrapes Well-Known Member

    Joined:
    Jul 28, 2010
    Posts:
    557
    Trophy Points:
    117
    Likes:
    +3
    A spring-loaded missile launcher isn't that complicated of a thing. There really can only be a few possibilities:

    1) the trigger: you say the "tooth" is still there. Does it look worn/broken? Does the trigger engage by moving up and then back down when a missile is inserted, as LCDR asked?

    2) the missiles: are you sure you have the right ones? Check some online pictures. Are the notches/brackets where the trigger engages in good shape?

    3) the spring: wrong spring/replacement spring might be too long or too strong. Again, as LCDR asked, is the trigger engaging when you insert it?

    Finally, send some pictures if the problem persists. Ideally, disassembled trigger and the missiles.
     
  4. brr-icy

    brr-icy G1 Collector

    Joined:
    Feb 7, 2008
    Posts:
    15,968
    News Credits:
    7
    Trophy Points:
    302
    Likes:
    +1,082
    Ebay:
    the spring is weakened. it takes a lot of force to lock the missiles in, and that's heavily dependent on the strength of the spring, happens over time if the missiles/fists, etc are left in the launchers. the spring pushes back on the flat downward side of the trigger. if there isn't enough force, the flat side doesn't stay back, resulting in the misfires
     
  5. LCDR Blindside

    LCDR Blindside Banned

    Joined:
    Apr 1, 2012
    Posts:
    4,527
    News Credits:
    1
    Trophy Points:
    151
    Likes:
    +3
    Brr-icy's probably got it.

    Also, is the missile itself worn down?
     
  6. Soundblaster1

    Soundblaster1 The Heisenberg of Toys

    Joined:
    Oct 4, 2004
    Posts:
    14,024
    News Credits:
    11
    Trophy Points:
    257
    Likes:
    +16
    1) the trigger: you say the "tooth" is still there. Does it look worn/broken? Does the trigger engage by moving up and then back down when a missile is inserted, as LCDR asked?
    Trigger engages, "tooth" looks fine
    2) the missiles: are you sure you have the right ones? Check some online pictures. Are the notches/brackets where the trigger engages in good shape?
    They're the correct missiles and they look fine.

    3) the spring: wrong spring/replacement spring might be too long or too strong. Again, as LCDR asked, is the trigger engaging when you insert it?
    This is the 3rd time I've had this mold and the first time I've had an issue. The spring looks fine and I'm not seeing anything out of the ordinary.

    I'd love to take it apart, but it's glued together and I don't feel like breaking it.

    I've been doing this for years. I certainly didn't say "Spring-loaded missile launchers are too complicated for me to figure out". This is the second time I've ever seen the problem (I've had hundreds of figures with spring loaded missile launchers, and I've only been posting here since 2004 so I'd at least be clued in if this were common and/or anyone cared), and I'm yet to figure out a suitable solution.
     
  7. brr-icy

    brr-icy G1 Collector

    Joined:
    Feb 7, 2008
    Posts:
    15,968
    News Credits:
    7
    Trophy Points:
    302
    Likes:
    +1,082
    Ebay:
    i had to take apart my g1 trailbreaker because of it, and g2 jazz's launcher, only thing i could do is replace the spring, not sure what to do when the launcher is glued, maybe the heat up the glue trick?
     
  8. Fishdirt

    Fishdirt Tin Toy Transformer

    Joined:
    Sep 22, 2010
    Posts:
    3,646
    News Credits:
    3
    Trophy Points:
    172
    Likes:
    +7
    Ebay:
    post a clear video of the issue from different angles.
     
  9. Soundblaster1

    Soundblaster1 The Heisenberg of Toys

    Joined:
    Oct 4, 2004
    Posts:
    14,024
    News Credits:
    11
    Trophy Points:
    257
    Likes:
    +16
    Or I could take the launcher apart, squeeze the spring, and apparently fix the problem. Points to brr-icy and my needle-nose pliers for being useful.
     
  10. Erland

    Erland Well-Known Member

    Joined:
    Jan 30, 2012
    Posts:
    3,982
    News Credits:
    2
    Trophy Points:
    187
    Likes:
    +50
    That is funny, I just got my collection back up out of boxes after about 5 months in storage, my transtulas is doing the exact same thing.

    Before I stored it, everything worked without issue, I tested it before packing and didn't store the missile, that is attached via string to the character, in the character. I left it out.

    when I went to put the figure back up on the shelf this weekend, the missile wouldn't lock unless I push the locking mech down, then as soon as I let go, it fires.
     
  11. Soundblaster1

    Soundblaster1 The Heisenberg of Toys

    Joined:
    Oct 4, 2004
    Posts:
    14,024
    News Credits:
    11
    Trophy Points:
    257
    Likes:
    +16
    Had the figure hanging from the grappling missile while I was away for the weekend. Damn thing won't hold the missile now that I'm back, and my attempts to fix it have made it worse. Even tried a completely new spring.
     
  12. Maetel

    Maetel Well-Known Member

    Joined:
    Aug 19, 2006
    Posts:
    1,001
    Trophy Points:
    161
    Likes:
    +1
    i just found out my classics dinobot's missile doesn't lock in the launcher (anymore?) no big loss, the weapon/missile was stupid looking anyway.
     
  13. Jetbolt

    Jetbolt Maximal Air Commander

    Joined:
    Dec 6, 2009
    Posts:
    18,728
    News Credits:
    19
    Trophy Points:
    317
    Location:
    Ararat, NC
    Likes:
    +13,793
    Ebay:
    Facebook:
    Twitter:
    Google+:
    Instagram:
    Flickr:
    YouTube:
    I had a missile from HFTD Tomahawk that wouldn't stay in palace. So I ended using super glue on that side, as I really didn't use that feature much.
     
  14. levandowski

    levandowski Well-Known Member

    Joined:
    May 6, 2010
    Posts:
    930
    News Credits:
    2
    Trophy Points:
    147
    Likes:
    +100
    Ebay:
    Facebook:
    Instagram:
    I've had this problem with my bw tarantulas
     
  15. Maetel

    Maetel Well-Known Member

    Joined:
    Aug 19, 2006
    Posts:
    1,001
    Trophy Points:
    161
    Likes:
    +1
    any one notice this problem on the 10th anniversary tarrantulas? (thinking about getting one)
     
  16. Soundblaster1

    Soundblaster1 The Heisenberg of Toys

    Joined:
    Oct 4, 2004
    Posts:
    14,024
    News Credits:
    11
    Trophy Points:
    257
    Likes:
    +16
    The 10th Tarantulas is my offending figure.
     

Share This Page