Issue with Warbot Defender

Discussion in 'Transformers 3rd Party Discussion' started by Hothouse Prime, May 3, 2012.

  1. Hothouse Prime

    Hothouse Prime Not old... Just older.

    Joined:
    Apr 5, 2012
    Posts:
    775
    Trophy Points:
    132
    Location:
    OTPNE
    Likes:
    +76
    I wasn't sure where to post this, but this seemed as good a place as any...

    I received my Warbot Defender yesterday and upon taking it out of the package I noticed two black slivers of plastic in the weapons bag. Come to find out these were the c-clip that was supposed to hold the sword halves together. I know that BBTS has really good customer service, but wasn't sure if the piece was a necessity or if anyone else has had this problem.

    Any input or suggestions would be greatly appreciated...
     
  2. brr-icy

    brr-icy G1 Collector

    Joined:
    Feb 7, 2008
    Posts:
    15,968
    News Credits:
    7
    Trophy Points:
    302
    Likes:
    +1,082
    Ebay:
    contact bbts, i haven't heard of this problem before at all, they should replace it for you
     
  3. harrismonkey

    harrismonkey Well-Known Member

    Joined:
    Apr 10, 2009
    Posts:
    5,936
    News Credits:
    1
    Trophy Points:
    247
    Likes:
    +705
    Mine is in a box in the basement, so I can't see if they are supposed to come apart. But I can tell you they need to be attached to form the helicopter blades. I've never seen them separated.

    I also know mine came attached.

    See if yours will connect securely. If they won't, contact BBTS (it sounds like that's where you got this).
     
  4. dre_203

    dre_203 Active Member

    Joined:
    Jul 5, 2005
    Posts:
    35
    Trophy Points:
    76
    Likes:
    +0
    Ebay:
    I've had my warbot defender since it was first released and over the past year I have noticed hairline cracks appearing all over the figure. I've had my warbot on display but periodically switch him between his three modes. I ordered another one and plan on keeping it in the box. Anyone else having this problem?
     
  5. jnguyen

    jnguyen Well-Known Member

    Joined:
    Jan 23, 2010
    Posts:
    933
    News Credits:
    6
    Trophy Points:
    117
    Likes:
    +7
    Mine has hairline crack as well around where all the screws are. Especially on his legs.
     
  6. Hothouse Prime

    Hothouse Prime Not old... Just older.

    Joined:
    Apr 5, 2012
    Posts:
    775
    Trophy Points:
    132
    Location:
    OTPNE
    Likes:
    +76
    Thanks for all the input. In related news, BBTS is going to send me a replacement clip...

    As far as hairline cracks, haven't seen this problem yet. Hoping it isn't inherent to the figure.
     
  7. DisappearingOne

    DisappearingOne Well-Known Member

    Joined:
    May 4, 2012
    Posts:
    123
    Trophy Points:
    62
    Likes:
    +19
    Got my Warbot last week and the exact same thing happened to mine. Pulled the sword out of the bag and it then proceeded to fall apart on me. Haven't contacted BBTS about it yet, but they're usually pretty good with returns.
     
  8. jbz

    jbz Well-Known Member

    Joined:
    Apr 5, 2012
    Posts:
    4,505
    News Credits:
    1
    Trophy Points:
    167
    Likes:
    +2
    shit, I haven't opened my Warbot yet. I better go check now, LOL.
     
  9. RICEMASTER

    RICEMASTER Special Agent Doofy

    Joined:
    Oct 10, 2010
    Posts:
    2,381
    Trophy Points:
    217
    Likes:
    +2,953
    Instagram:
    Flickr:
    I had the same problem when i got mines a couple of weeks ago!!! I sent picks to bbts and they sent another blades/sword assembly...Contact them asap with pics!!! BBTS has great customer service so you should be ok!!!
     
  10. felyxz

    felyxz Active Member

    Joined:
    Nov 19, 2006
    Posts:
    43
    Trophy Points:
    36
    Likes:
    +0
    Ebay:
    and this is why I love buying from BBTS vs.other places that sell 3rd party products. Great customer service.
     
  11. Hothouse Prime

    Hothouse Prime Not old... Just older.

    Joined:
    Apr 5, 2012
    Posts:
    775
    Trophy Points:
    132
    Location:
    OTPNE
    Likes:
    +76
    Yep, BBTS already invoiced my account for the part. They've been great to work with. Couldn't be happier with the outcome.
     
  12. DisappearingOne

    DisappearingOne Well-Known Member

    Joined:
    May 4, 2012
    Posts:
    123
    Trophy Points:
    62
    Likes:
    +19
    This little plastic clip is quickly becoming the bane of my existance. Received the replacement from BBTS today, only to find the new one is the same as the old one, which is too big to clip on to the grey piece and hold the whole thing together. Unless they have another solution, I'm about ready to cut my losses and return WD.
     
  13. Sammael

    Sammael MightyMegatron from ATT

    Joined:
    Jan 10, 2007
    Posts:
    3,557
    News Credits:
    16
    Trophy Points:
    292
    Location:
    Belgrade, Serbia
    Likes:
    +444
    Wait, what clip? The clip that comes with Warbot Defender is meant to attach him to a flight stand, not to hold the blades together...
     
  14. DisappearingOne

    DisappearingOne Well-Known Member

    Joined:
    May 4, 2012
    Posts:
    123
    Trophy Points:
    62
    Likes:
    +19
    Its the tiny little black clip (clamp?) that's supposed to hold the sword together. Not talking about that grey flight stand thingie.
     
  15. harrismonkey

    harrismonkey Well-Known Member

    Joined:
    Apr 10, 2009
    Posts:
    5,936
    News Credits:
    1
    Trophy Points:
    247
    Likes:
    +705

    Although it is sounding like something may have gone wrong with what ever run these newly shipped figures are coming from (3 issues in this thread?)-

    Mine (from the original run) consists of two black sword halves which are help together by a gray peg where the handle meets the blade. The peg plugs into the body (in helicopter mode) and the two sword halves rotate on this peg going from 1 sword blade to 2 copter blades.

    I have absolutely no idea what black clamp you're talking about. Did they change the color of something? Maybe even add a part?
     
  16. Dio

    Dio Scrapper

    Joined:
    Dec 22, 2003
    Posts:
    1,401
    Trophy Points:
    177
    Likes:
    +6
    I had the same issue with the clip being too loose and having a crack, but a little superglue fixed it. I don't mind the sword having a permanent peg thru it, and the blades still spin. The design could have been much better though.
     
  17. AlphaFool

    AlphaFool Well-Known Member

    Joined:
    Jan 18, 2008
    Posts:
    56
    News Credits:
    1
    Trophy Points:
    46
    Likes:
    +1
    Yeah, mine is exactly how you described it. My Warbot is from the original run, and it came with two swords being held together by a peg. I'm not aware of this black clip/clamp. Can anyone post pictures to clarify?
     
  18. Kuma Style

    Kuma Style Toy Photography TFW2005 Supporter

    Joined:
    Dec 6, 2010
    Posts:
    24,503
    News Credits:
    13
    Trophy Points:
    387
    Likes:
    +3,099
    Ebay:
    Facebook:
    Twitter:
    Instagram:
    Flickr:
    YouTube:
    Pinterest:
    Mine's from the first run as well, and there's a black clip on the gray peg.... without it, the sword pieces slide off of it and don't stay together naturally for sword mode.
     

Share This Page