is something wrong with my prime?

Discussion in 'Transformers Toy Discussion' started by Fallout, Apr 26, 2012.

  1. Fallout

    Fallout Well-Known Member

    Joined:
    Nov 26, 2011
    Posts:
    13,193
    News Credits:
    2
    Trophy Points:
    277
    Likes:
    +1,757
    on my dotm deluxe optimus prime, when changing him to vehiclr mode, one of the legs tabs on fine but when i slide the other one up it only goes up to just below the spot where the tab goes. am i doing something wrong? does quality control strike again?
     
  2. ex dtw2003

    ex dtw2003 Well-Known Member

    Joined:
    Jul 20, 2011
    Posts:
    6,982
    News Credits:
    1
    Trophy Points:
    247
    Likes:
    +307
    Pictures would help a lot with this if possible.
     
  3. Fallout

    Fallout Well-Known Member

    Joined:
    Nov 26, 2011
    Posts:
    13,193
    News Credits:
    2
    Trophy Points:
    277
    Likes:
    +1,757
    [​IMG]

    circled the problem area in red.
     
  4. Aernaroth

    Aernaroth <b><font color=blue>I voted for Super_Megatron and Veteran

    Joined:
    Mar 27, 2004
    Posts:
    24,392
    News Credits:
    2
    Trophy Points:
    367
    Likes:
    +1,360
    Looks like lupus to me.
     
  5. Snake_eyes1975

    Snake_eyes1975 Peace through Tyranny!!

    Joined:
    Sep 14, 2010
    Posts:
    7,439
    News Credits:
    3
    Trophy Points:
    247
    Location:
    Michigan
    Likes:
    +484
    Ebay:
    I have the reg Wal mart deluxe that has the same leg issue. Just took some fiddlin it it smothed out.

    The Lunar fire I got for a Christmas present was flawless.
     
  6. Maetel

    Maetel Well-Known Member

    Joined:
    Aug 19, 2006
    Posts:
    1,001
    Trophy Points:
    161
    Likes:
    +1
    it's never lupus
     
  7. vladimir-pocket

    vladimir-pocket Decepticon

    Joined:
    Dec 21, 2010
    Posts:
    234
    News Credits:
    3
    Trophy Points:
    77
    Location:
    Baltimore, MD
    Likes:
    +19
    iv owned that mold 3 times, each one had the leg issue, it also dosnt stay in robot mode... only on 1 side though
     
  8. ex dtw2003

    ex dtw2003 Well-Known Member

    Joined:
    Jul 20, 2011
    Posts:
    6,982
    News Credits:
    1
    Trophy Points:
    247
    Likes:
    +307
    Best guess is that you aren't getting it fully rotated for the collapse. That mold uses cheap plastic (IMHO) and the joints can be really stiff.
     
  9. Fallout

    Fallout Well-Known Member

    Joined:
    Nov 26, 2011
    Posts:
    13,193
    News Credits:
    2
    Trophy Points:
    277
    Likes:
    +1,757
    so it's not just mine eh? that kinda makes me feel better. any known way to fix it?
     
  10. Fallout

    Fallout Well-Known Member

    Joined:
    Nov 26, 2011
    Posts:
    13,193
    News Credits:
    2
    Trophy Points:
    277
    Likes:
    +1,757
    so no way to fix it? anyone?
     
  11. Snake_eyes1975

    Snake_eyes1975 Peace through Tyranny!!

    Joined:
    Sep 14, 2010
    Posts:
    7,439
    News Credits:
    3
    Trophy Points:
    247
    Location:
    Michigan
    Likes:
    +484
    Ebay:
    I dunno man, Its hard to tell with your pics.

    I guess grab an exacto and try to make the bad side look like the good side? Mabye take some better pics and Ill try to help
     

Share This Page