HA mudflap

Discussion in 'Transformers Toy Discussion' started by CVprowl, May 12, 2011.

  1. CVprowl

    CVprowl FREEDOM FIGHTER

    Joined:
    Jan 20, 2011
    Posts:
    8,077
    Trophy Points:
    212
    Likes:
    +60
    i just got this guy and im trying to get him to bot mode.

    does the chest piece actually tab into the pelvic piece like it looks like its supposed to (and like it does on skids)? it seems like push/pull/pry i cant get it to reach.

    has anyone actually done this or is this a glitch with the figure?
     
  2. jametron

    jametron Release the Kraken!!!!!!!

    Joined:
    Dec 26, 2007
    Posts:
    6,394
    News Credits:
    1
    Trophy Points:
    197
    Likes:
    +10
    It does indeed tab in, but you have to make sure the dark gray pieces of the bumper are pulled down as well. IIRC, that part is pretty vague in the instructions... Anyway, they're on sliding hinges, pull them down and tab them into the torso piece, then the torso piece should lock onto the pelvis part, just like Skids.

    Hope that helps!
     
  3. Vadricon

    Vadricon Member

    Joined:
    Aug 17, 2009
    Posts:
    16
    Trophy Points:
    31
    Likes:
    +0
    It does tab into place. I don't have mine handy atm but I seem to remember that that tab from the hood section itself slides forward or back to line up with the slot on the pelvis.
     
  4. CVprowl

    CVprowl FREEDOM FIGHTER

    Joined:
    Jan 20, 2011
    Posts:
    8,077
    Trophy Points:
    212
    Likes:
    +60
    sounds good, let me try it again. :) 
     
  5. CVprowl

    CVprowl FREEDOM FIGHTER

    Joined:
    Jan 20, 2011
    Posts:
    8,077
    Trophy Points:
    212
    Likes:
    +60
    awesome guys, i hadnt pulled down those grey bumper pieces to tab into the chest and get it lined up to slide into the pelvis. looks perfect now. : )
     
  6. jametron

    jametron Release the Kraken!!!!!!!

    Joined:
    Dec 26, 2007
    Posts:
    6,394
    News Credits:
    1
    Trophy Points:
    197
    Likes:
    +10
    Cool, glad you got it... I had the exact same problem when first transforming mine. It took me a little while to notice/discover that those gray pieces slid down.
     

Share This Page