GF DVD playback problem

Discussion in 'Transformers General Discussion' started by j3, Mar 19, 2006.

  1. j3

    j3 Kiefer is my Big Boss TFW2005 Supporter

    Jul 8, 2003
    Trophy Points:
    Okay, watching Galaxy Force DVDs on a Philips DVP642 set to region 0 (though tried setting to 2 and had same problem), running through a coaxial digital audio cable (though also tried optical with same problem) and at just about every chapter mark (and there's a lot on these discs) the audio will drop out for about second and come back. I also tried updating the firmware to the latest, to no avail. Spoke with someone else who had the same problem with another region free player. Reportedly I can hook up a set of analog cables and it'd play fine but that's such a hassle for just these discs. It's not every R2 that does it though, the Zeta movie R2s play fine, even if I switch to the stereo track instead of the 5.1. I can't imagine they'd do the same thing in an actual R2 player though, you'd think something like that would be quite a recall on the discs. But I also can't see why it'd do it on something set to all regions when the audio would be left alone anyway.

    So I know there's at least a few of you out there who are also importing the GF DVDs; what are you playing on, and any problems?
  2. Nightrain

    Nightrain Senior Villain

    Jul 1, 2002
    News Credits:
    Trophy Points:
    It's pretty meaningless, but I only have the one disc that came with Chromia, and had no problems on my J PS2.

Share This Page