Bumblebee parts

Discussion in 'Transformers Toy Discussion' started by Tigertrack, Aug 5, 2010.

  1. Tigertrack

    Tigertrack Back In The Game!

    Joined:
    Feb 8, 2010
    Posts:
    7,054
    Trophy Points:
    176
    Likes:
    +2
    Okay, so I was playing with my movie Bumblebee figure today along with my Generations Thrust. I was trying to transform Bumblebee and man is he complicated!
    All of a sudden, these two pieces popped off and I have no clue where they came from! Any ideas?
    [​IMG]
    [​IMG]
    I thought they went on the side of his upper thighs, but they don't seem to fit anywhere. Their obviously BB parts, but where?
    They didn't brake off fortunately, just popped off and I'd like to put them back on. And no, that yellow speck between the parts is not from the parts or figure at all. Something else..................
     
  2. Grimlock_13

    Grimlock_13 Reformed Geewunner

    Joined:
    Dec 7, 2002
    Posts:
    23,600
    News Credits:
    2
    Trophy Points:
    327
    Location:
    Boise, ID
    Likes:
    +83
    They go on the outside of its' shoulders. There should be rectangular pegs on the pieces that slide into slots on the arms.
     
  3. bouncing boy77

    bouncing boy77 Syntax Error

    Joined:
    Jun 20, 2007
    Posts:
    3,301
    Trophy Points:
    172
    Likes:
    +1
    those are his shoulder pads. they really tend to pop off from time to time. i got the 1st version of the camaro bb from the 1st movie and glued it up so it wont come off again. hope this helps!
     
  4. Tigertrack

    Tigertrack Back In The Game!

    Joined:
    Feb 8, 2010
    Posts:
    7,054
    Trophy Points:
    176
    Likes:
    +2
    Pictures would be nice please. And thank you!
     
  5. bouncing boy77

    bouncing boy77 Syntax Error

    Joined:
    Jun 20, 2007
    Posts:
    3,301
    Trophy Points:
    172
    Likes:
    +1
  6. Tigertrack

    Tigertrack Back In The Game!

    Joined:
    Feb 8, 2010
    Posts:
    7,054
    Trophy Points:
    176
    Likes:
    +2
    Thank's guys! I think I've got it fixed now...............
     

Share This Page