Armada Galvatron Question

Discussion in 'Transformers Toy Discussion' started by Lumen, Jun 30, 2012.

  1. Lumen

    Lumen Active Member

    Joined:
    Jun 5, 2012
    Posts:
    25
    Trophy Points:
    36
    Likes:
    +0
    Recently I've been noticing that the turret part of my armada galvatron is kind of loose in that it won't stay in place sometimes when I angle it a certain way when galvatron is standing up. It did this before, but I fixed it. In addition to this, the little peg you use to keep the turret in place, won't rotate the turret anymore when I move it. I have taken it apart again and it seems as thought the little gears aren't making contact. Is this a common problem with all Galvatrons (armada), or is there a way to fix this?
     
  2. MidnightBliss

    MidnightBliss Well-Known Member

    Joined:
    Nov 24, 2008
    Posts:
    4,149
    Trophy Points:
    172
    Likes:
    +16
    Mine is faulty as well. For me, it seems that the gear that is glued to the pin that turns is loose. I can't get it off to put more glue on it. Soooooo, no more spinny gun tummy for me.
     
  3. Gingerchris

    Gingerchris Telly-headed Tyrant

    Joined:
    Feb 17, 2005
    Posts:
    14,917
    News Credits:
    7
    Trophy Points:
    287
    Likes:
    +223
    I've got a couple of Armada Galvatrons and both have this issue. To be honest though I've not bothered to try and fix it.
     
  4. Wolfdawg

    Wolfdawg Well-Known Member

    Joined:
    May 12, 2009
    Posts:
    1,884
    News Credits:
    2
    Trophy Points:
    197
    Likes:
    +459
    That's weird. I have Botcon Megazarak and Armada Galvatron and neither has the issues you're describing.
     

Share This Page