Animated Bumblebee hood issues

Discussion in 'Transformers Toy Discussion' started by MnemonicSyntax, Mar 7, 2009.

  1. MnemonicSyntax

    MnemonicSyntax Rooks Gang Leader

    Joined:
    Jul 22, 2007
    Posts:
    5,400
    News Credits:
    1
    Trophy Points:
    227
    Likes:
    +196
    Hey guys,

    I've gone through three Deluxe Animated Bumblebees (the yellow version) and every single one has an issue with the hood when going into leg formation! The issue is always the one WITHOUT the siren, it freakin' falls off all the time, but the other one stays on fine!

    Any suggestions on how to repair this?! It's so frustrating regarding the transformation of the little guy!
     
  2. Bgrngod

    Bgrngod Autocon

    Joined:
    Oct 9, 2007
    Posts:
    6,108
    News Credits:
    35
    Trophy Points:
    176
    Likes:
    +35
    That sucks. Three in a row?

    I've never had this issue at all.
     
  3. MEGAMAN X FAN

    MEGAMAN X FAN Well-Known Member

    Joined:
    May 30, 2008
    Posts:
    619
    News Credits:
    7
    Trophy Points:
    101
    Likes:
    +7
    it should just pop back on
     
  4. MnemonicSyntax

    MnemonicSyntax Rooks Gang Leader

    Joined:
    Jul 22, 2007
    Posts:
    5,400
    News Credits:
    1
    Trophy Points:
    227
    Likes:
    +196
    It does go back on (well, one of them doesn't, it's like the hole is too big.) I've even swapped hoods to see if one fit better than the other. I can pull the one with the siren down, flip it around, no problem. The one without the siren pops right off, when I try to move it into position.

    Animated's QC seems to not be so swell, eh?

    Anyway, the issue is that it appears that the hole is kind of big. Any ideas to fix it?
     
  5. xxxJackxxx

    xxxJackxxx TF Reviewer

    Joined:
    Mar 6, 2009
    Posts:
    15
    Trophy Points:
    31
    Likes:
    +0
    I Don't What Your Error Is,I've Never Heard Of Such Thing!
     
  6. Torque

    Torque The WORDSMITH

    Joined:
    Dec 17, 2007
    Posts:
    11,327
    News Credits:
    6
    Trophy Points:
    221
    Likes:
    +6
    try the mod to tighten the ball joints, and be a little gentler.
     
  7. Donovan

    Donovan Member

    Joined:
    Jan 11, 2009
    Posts:
    11
    Trophy Points:
    31
    Likes:
    +0
    You are not alone with this problem. At least a couple of other people I know of have this problem including myself. Another issue are the arms if they do not get incredibly loose or just easily pop off with little pressure.
     
  8. BrokenSVT

    BrokenSVT It's not broken anymore.

    Joined:
    Feb 28, 2008
    Posts:
    1,323
    Trophy Points:
    126
    Likes:
    +0
    I have the same issue with both my second yellow BB and with my Stealth BB. The joints can be carved deeper, and nail polish added to the ball. That fixed mine fine.
     
  9. MnemonicSyntax

    MnemonicSyntax Rooks Gang Leader

    Joined:
    Jul 22, 2007
    Posts:
    5,400
    News Credits:
    1
    Trophy Points:
    227
    Likes:
    +196
    This is ridiculous. I just want to contact Hasbro over this.

    It's nothing about being gentle, I cannot move the panel at all without having it fall off.

    Maybe I'll get an Activators Bumblebee instead.
     
  10. thenatureboywoo

    thenatureboywoo Veteran

    Joined:
    Dec 15, 2008
    Posts:
    8,206
    News Credits:
    3
    Trophy Points:
    207
    Likes:
    +18
    You're just gonna have to deal with it for a while. Mine kept popping off, but after a while, the joint "wore in", and now mine doesn't pop off. Even if it pops off, it sill goes back on so i don't see why it's that big of a deal.
     
  11. Orion_Prime48

    Orion_Prime48 Super Sentai Purist

    Joined:
    Dec 18, 2007
    Posts:
    8,355
    News Credits:
    3
    Trophy Points:
    176
    Likes:
    +3
    wow after 2 id have given up and dealt with it lol hopefully whenever I get the deluxe Bee I dont have that problem but I just need to find him so I can get him
     

Share This Page